CVE-2026-46710
NoneCVSS
—
EPSS
0.2%
Published
Jun 26, 2026
CISA due date
—
The record
Notepad++ is a free and open-source source code editor. From 8.9.4 until 8.9.6, Notepad++ contains a local privilege escalation vulnerability in the installer. During installation, the installer invokes powershell.exe without using an absolute path after setting the working directory to the installation contextMenu directory. If an attacker can pre-place a malicious powershell.exe in a user-writable custom installation directory, and a privileged user later runs the installer and selects that directory, the attacker-controlled executable is launched with the elevated privileges of the installer. This vulnerability is fixed in 8.9.6.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-0307 Multiple local privilege escalation vulnerabilities in the Palo Alto Networks… CWE-426
- CVE-2026-81192 `OpenTelemetry.Resources.Host` NuGet package, which provides OpenTelemetry resource… CWE-426
- CVE-2026-80159 Acrobat Reader is affected by an Untrusted Search Path vulnerability that could result in… CWE-426
- CVE-2026-84226 OpenVPN version 2.5.0 through 2.6.22 and 2.7_alpha1 through 2.7.6 on Windows allows local… CWE-426
- CVE-2026-82862 Hulumi versions before v1.3.2 resolve the threat-model helper script from an unsafe root… CWE-426
- CVE-2026-75768 Substance3D - Painter is affected by an Untrusted Search Path vulnerability that could… CWE-426
- CVE-2026-78680 NLTK versions before 3.10.3 fail to use validated absolute paths when invoking the… CWE-426
- CVE-2026-16869 IBM AIX 7.2, and 7.3 and IBM PowerVM VIOS 4.1 could allow a local attacker to execute… CWE-426