CVE-2026-45719
Medium · 6.5CVSS
6.5
EPSS
0.4%
Published
May 27, 2026
CISA due date
—
The record
Budibase is an open-source low-code platform. Prior to 3.38.1, the V1 Views API (POST /api/views) accepts a calculation parameter from the request body that is interpolated directly into a CouchDB reduce function definition without validation. Although an internal SCHEMA_MAP object defines the valid calculation types (sum, count, stats), no actual validation is performed against this map before the value is used in string interpolation. A user with Builder permissions can inject arbitrary JavaScript code that will be executed within the CouchDB JavaScript engine when the view is queried. This vulnerability is fixed in 3.38.1.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @budibase/server | 0 | 3.38.1 |
Related vulnerabilities
- GHSA-363w-hvwh-w7m6 Budibase: CouchDB Reduce Injection via Unsanitized Calculation Parameter in V1 Views API Same vulnerability
- GHSA-3gp5-q4jw-3v94 Budibase: Basic app users can exfiltrate stored REST datasource auth by rewriting… Also affects @budibase/server
- GHSA-qhv3-wjg8-6fx6 Budibase: Webhook schema endpoint authorization bypass allows unauthenticated mutation of… Also affects @budibase/server
- GHSA-6xp4-cf37-ppjh Budibase: Workspace-scoped builder escalates to global admin via… Also affects @budibase/server
- GHSA-cv96-5348-p5p8 Budibase: Unvalidated VectorDB Host Parameter Enables SSRF Also affects @budibase/server
- GHSA-g6qx-g4pr-92v7 Budibase: SSRF via OAuth2 Config Validation — Missing fetchWithBlacklist Protection Also affects @budibase/server
- CVE-2026-48148 Budibase is an open-source low-code platform. Also affects @budibase/server
- CVE-2026-48152 Budibase is an open-source low-code platform. Also affects @budibase/server