CVE-2026-45717
High · 8.8CVSS
8.8
EPSS
0.4%
Published
May 27, 2026
CISA due date
—
The record
Budibase is an open-source low-code platform. Prior to 3.38.1, Budibase exposes a REST API for datasource management. The route PUT /api/datasources/:datasourceId is registered in the authorizedRoutes group with TABLE/READ permission. This is the same authorization level as the read endpoint (GET /api/datasources/:datasourceId). Every authenticated Budibase app user with the BASIC built-in role or higher carries TABLE/WRITE (and therefore TABLE/READ) permissions, and the datasource update controller performs no additional builder check. As a result, any authenticated non-builder app user can submit a PUT request to rewrite a datasource's config object — including the connection host, port, database credentials, or the base url of a REST datasource. Because no network-level SSRF protection is applied to SQL driver connections, redirecting a PostgreSQL/MySQL/MongoDB datasource to an internal IP address succeeds and the attacker can probe or interact with internal services on arbitrary ports. This vulnerability is fixed in 3.38.1.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @budibase/server | 0 | 3.38.1 |
Related vulnerabilities
- GHSA-44m2-crh7-f4q2 Budibase: `PUT /api/datasources/:datasourceId` is protected only by `TABLE/READ`… Same vulnerability
- GHSA-3gp5-q4jw-3v94 Budibase: Basic app users can exfiltrate stored REST datasource auth by rewriting… Also affects @budibase/server
- GHSA-qhv3-wjg8-6fx6 Budibase: Webhook schema endpoint authorization bypass allows unauthenticated mutation of… Also affects @budibase/server
- GHSA-6xp4-cf37-ppjh Budibase: Workspace-scoped builder escalates to global admin via… Also affects @budibase/server
- GHSA-cv96-5348-p5p8 Budibase: Unvalidated VectorDB Host Parameter Enables SSRF Also affects @budibase/server
- GHSA-g6qx-g4pr-92v7 Budibase: SSRF via OAuth2 Config Validation — Missing fetchWithBlacklist Protection Also affects @budibase/server
- CVE-2026-48148 Budibase is an open-source low-code platform. Also affects @budibase/server
- CVE-2026-48152 Budibase is an open-source low-code platform. Also affects @budibase/server