CVE-2026-43944
Critical · 9.6CVSS
9.6
EPSS
0.6%
Published
May 8, 2026
CISA due date
—
The record
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | electerm | 3.0.6 | 3.8.8 |
Related vulnerabilities
- GHSA-mpm8-cx2p-626q Electerm users can run dangrous code through link or command line Same vulnerability
- CVE-2026-45353 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- CVE-2026-45787 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- CVE-2026-45058 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- GHSA-g29v-q6h7-76wh electerm's encrypt method not safe enough Also affects electerm
- GHSA-7p5m-v798-f8vv Electerm Local code through electerm's single-instance socket Also affects electerm
- GHSA-jgg9-rw32-44pj Electerm: Importing unsafe bookmark data could lead to unsafe operation when clicking… Also affects electerm
- GHSA-q4p8-8j9m-8hxj Electerm Security Vulnerability: RCE via malicious SSH server filename in… Also affects electerm