CVE-2026-43940
High · 8.4CVSS
8.4
EPSS
0.2%
Published
May 8, 2026
CISA due date
—
The record
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.7.16, the runWidget function in src/app/widgets/load-widget.js constructs a file path by directly concatenating user‑supplied widget identifiers without any sanitisation. Because runWidget is exposed to the renderer process via an asynchronous IPC handler with no input validation, an attacker who achieves JavaScript execution inside the renderer (for example, through a malicious plugin or a cross‑site scripting flaw in the built‑in webview) can abuse a path traversal (../) to load and execute an arbitrary JavaScript file anywhere on the victim’s filesystem. This gives the attacker local code execution with the full privileges of the electerm process, leading to complete system compromise. This issue has been patched in version 3.7.16.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | electerm | 0 | 3.7.16 |
Related vulnerabilities
- GHSA-f77v-9vpc-6pjm Electerm runWidget has a path traversal that leads to arbitrary code execution Same vulnerability
- CVE-2026-45353 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- CVE-2026-45787 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- CVE-2026-45058 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- GHSA-g29v-q6h7-76wh electerm's encrypt method not safe enough Also affects electerm
- GHSA-7p5m-v798-f8vv Electerm Local code through electerm's single-instance socket Also affects electerm
- GHSA-jgg9-rw32-44pj Electerm: Importing unsafe bookmark data could lead to unsafe operation when clicking… Also affects electerm
- GHSA-mpm8-cx2p-626q Electerm users can run dangrous code through link or command line Also affects electerm