CVE-2026-42268
High · 7.5CVSS
7.5
EPSS
0.5%
Published
May 12, 2026
CISA due date
—
The record
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| openSUSE:Tumbleweed | modsecurity | 0 | 3.0.15-1.1 |
Related vulnerabilities
- CVE-2026-30923 ModSecurity is an open source, cross platform web application firewall (WAF) engine for… Also affects modsecurity
- CVE-2026-88833 A flaw was found in BusyBox's udhcpc DHCP client. CWE-191
- CVE-2026-44235 rabbitmq-c is a C-language AMQP client library for RabbitMQ. CWE-191
- CVE-2026-81977 Acrobat Reader is affected by an Integer Underflow (Wrap or Wraparound) vulnerability… CWE-191
- CVE-2026-66767 SAP NetWeaver Application Server for ABAP and ABAP Platform allows an unauthenticated… CWE-191
- CVE-2026-18341 IBM i 7.6, 7.5, 7.4, and 7.3 could allow a remote authenticated attacker to corrupt… CWE-191
- CVE-2026-9624 A denial-of-service security issue exists within RSLinx® Classic. CWE-191
- CVE-2026-9622 A denial-of-service security issue exists within RSLinx® Classic. CWE-191