Cloudanix VulnDB

CVE-2026-42076

Critical · 9.8

CVSS

9.8

EPSS

2.6%

Published

May 4, 2026

CISA due date

—

The record

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.

Affected packages

Ecosystem Package Introduced Fixed
npm @evomap/evolver 0 1.69.3

Related vulnerabilities