Cloudanix VulnDB

CVE-2026-4176

Critical · 9.8

CVSS

9.8

EPSS

0.8%

Published

Mar 29, 2026

CISA due date

—

The record

Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib. Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.

Affected packages

Ecosystem Package Introduced Fixed
Chainguard miniperl 0 5.42.2-r0
Chainguard perl 0 5.42.2-r0
Wolfi miniperl 0 5.42.2-r0
Wolfi perl 0 5.42.2-r0