CVE-2026-41501
Critical · 9.8CVSS
9.8
EPSS
2.5%
Published
May 8, 2026
CISA due date
—
The record
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | electerm | 0 | 3.3.8 |
Related vulnerabilities
- GHSA-8x35-hph8-37hq electerm has Command Injection via runLinux funtion Same vulnerability
- CVE-2026-45353 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- CVE-2026-45787 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- CVE-2026-45058 electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Also affects electerm
- GHSA-g29v-q6h7-76wh electerm's encrypt method not safe enough Also affects electerm
- GHSA-7p5m-v798-f8vv Electerm Local code through electerm's single-instance socket Also affects electerm
- GHSA-jgg9-rw32-44pj Electerm: Importing unsafe bookmark data could lead to unsafe operation when clicking… Also affects electerm
- GHSA-mpm8-cx2p-626q Electerm users can run dangrous code through link or command line Also affects electerm