Cloudanix VulnDB

CVE-2026-41268

Critical · 9.8

CVSS

9.8

EPSS

1.2%

Published

Apr 23, 2026

CISA due date

—

The record

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

Affected packages

Ecosystem Package Introduced Fixed
npm flowise 0 3.1.0
npm flowise-components 0 3.1.0

Related vulnerabilities