Cloudanix VulnDB

CVE-2026-40976

Critical · 9.1

CVSS

9.1

EPSS

0.5%

Published

Apr 28, 2026

CISA due date

—

The record

In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities