CVE-2026-35569
High · 8.7CVSS
8.7
EPSS
0.4%
Published
Apr 15, 2026
CISA due date
—
The record
ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in SEO-related fields (SEO Title and Meta Description), where user-controlled input is rendered without proper output encoding into HTML contexts including <title> tags, <meta> attributes, and JSON-LD structured data. An attacker can inject a payload such as "></title><script>alert(1)</script> to break out of the intended HTML context and execute arbitrary JavaScript in the browser of any authenticated user who views the affected page. This can be leveraged to perform authenticated API requests, access sensitive data such as usernames, email addresses, and roles via internal APIs, and exfiltrate it to an attacker-controlled server. This issue has been fixed in version 4.29.0.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | apostrophe | 0 | 4.29.0 |
Related vulnerabilities
- GHSA-855c-r2vq-c292 Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS Same vulnerability
- CVE-2026-45013 ApostropheCMS is an open-source Node.js content management system. Also affects apostrophe
- CVE-2026-45012 ApostropheCMS is an open-source Node.js content management system. Also affects apostrophe
- CVE-2026-45011 ApostropheCMS is an open-source Node.js content management system. Also affects apostrophe
- GHSA-5f64-7vfc-rcx6 Apostrophe has stored XSS via javascript: URL in Image Widget Link Also affects apostrophe
- GHSA-gf43-24g3-5hw2 Apostrophe has a Weak Password Recovery Mechanism for Forgotten Password and Improper… Also affects apostrophe
- GHSA-pr28-mf3q-qpg6 Apostrophe has authenticated SSRF in rich-text widget import via… Also affects apostrophe
- GHSA-c276-fj82-f2pq ApostropheCMS: Information Disclosure via choices/counts Query Parameters Bypassing… Also affects apostrophe