Cloudanix VulnDB

CVE-2026-35479

Medium · 6.6

CVSS

6.6

EPSS

0.4%

Published

Apr 8, 2026

CISA due date

—

The record

InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring "superuser" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities