Cloudanix VulnDB

CVE-2026-34573

High · 7.5

CVSS

7.5

EPSS

0.9%

Published

Mar 31, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.68 and 9.7.0-alpha.12, the GraphQL query complexity validator can be exploited to cause a denial-of-service by sending a crafted query with binary fan-out fragment spreads. A single unauthenticated request can block the Node.js event loop for seconds, denying service to all concurrent users. This only affects deployments that have enabled the requestComplexity.graphQLDepth or requestComplexity.graphQLFields configuration options. This issue has been patched in versions 8.6.68 and 9.7.0-alpha.12.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.68
npm parse-server 9.0.0 9.7.0-alpha.12

Related vulnerabilities