Cloudanix VulnDB

CVE-2026-33633

High · 7.5

CVSS

7.5

EPSS

0.5%

Published

May 19, 2026

CISA due date

—

The record

Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities