Cloudanix VulnDB

CVE-2026-33624

Low · 2.7

CVSS

2.7

EPSS

0.3%

Published

Mar 24, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.60 and 9.6.0-alpha.54, an attacker who obtains a user's password and a single MFA recovery code can reuse that recovery code an unlimited number of times by sending concurrent login requests. This defeats the single-use design of recovery codes. The attack requires the user's password, a valid recovery code, and the ability to send concurrent requests within milliseconds. This issue has been patched in versions 8.6.60 and 9.6.0-alpha.54.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.60
npm parse-server 9.0.0 9.6.0-alpha.54

Related vulnerabilities