CVE-2026-33508
High · 7.5CVSS
7.5
EPSS
0.6%
Published
Mar 24, 2026
CISA due date
—
The record
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.56 and 9.6.0-alpha.45, Parse Server's LiveQuery component does not enforce the requestComplexity.queryDepth configuration setting when processing WebSocket subscription requests. An attacker can send a subscription with deeply nested logical operators, causing excessive recursion and CPU consumption that degrades or disrupts service availability. This issue has been patched in versions 8.6.56 and 9.6.0-alpha.45.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | parse-server | 0 | 8.6.56 |
| npm | parse-server | 9.0.0 | 9.6.0-alpha.45 |
Related vulnerabilities
- GHSA-6qh5-m6g3-xhq6 Parse Server LiveQuery subscription query depth bypass Same vulnerability
- GHSA-97pr-9hgg-3p8r parse-server: LiveQuery discloses object data to a subscriber across an ACL read-access… Also affects parse-server
- GHSA-wmwx-jr2p-4j4r parse-server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL Also affects parse-server
- GHSA-7wqv-xjf3-x35v parse-server: Stored XSS via trailing-dot filename bypassing file upload extension… Also affects parse-server
- GHSA-p84r-h6rx-f2xr parse-server: Server option routeAllowList is bypassable through batch sub-requests Also affects parse-server
- GHSA-cgxm-vr2f-6fj8 parse-server: Denial of service via exponential-time processing of deeply nested query… Also affects parse-server
- CVE-2026-53726 Parse Server is an open source backend that can be deployed to any infrastructure that… Also affects parse-server
- CVE-2026-53724 Parse Server is an open source backend that can be deployed to any infrastructure that… Also affects parse-server