Cloudanix VulnDB

CVE-2026-33409

Critical · 9.1

CVSS

9.1

EPSS

0.6%

Published

Mar 24, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.52
npm parse-server 9.0.0 9.6.0-alpha.41

Related vulnerabilities