CVE-2026-3304
High · 7.5CVSS
7.5
EPSS
0.9%
Published
Feb 27, 2026
CISA due date
—
Cloudanix analysis
A flaw in a common web application component could allow an attacker to crash the service by sending a malformed request, making it unavailable for legitimate use.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Library
- Class
- Denial of service
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
An unauthenticated remote attacker can send specially crafted multipart/form-data requests to a web server using the vulnerable Multer middleware. The middleware fails to properly handle these malformed requests, leading to excessive resource consumption (CPU, memory, or file handles). This resource exhaustion ultimately causes the Node.js process to become unresponsive or crash, resulting in a denial of service (DoS).
Why it matters to the business
Exploitation of this vulnerability will result in a denial of service, making the affected web application or API unavailable to users and other services. This can lead to business disruption, loss of revenue, customer dissatisfaction, and reputational damage. Since the vulnerability is easy to exploit and requires no authentication, critical services could face prolonged outages if repeatedly targeted.
How an attack unfolds
An attacker identifies a web application using a vulnerable version of the Multer middleware, which is common in Node.js applications that handle file uploads. The attacker then crafts a malicious multipart/form-data HTTP request that is intentionally malformed in a way the Multer library cannot process correctly. Upon receiving this request, the server's Multer middleware enters a state where it consumes excessive system resources. By sending a single or a small number of these requests, the attacker can exhaust the server's resources, causing the application to slow down, become unresponsive, or crash entirely, denying service to legitimate users.
How to fix it
The primary remediation is to upgrade the Multer library to version 2.1.0 or later. This can be done by updating the project's package.json file to specify `"multer": "^2.1.0"` and running the appropriate package manager command (e.g., `npm install` or `yarn install`). According to the advisory, there are no known workarounds, so upgrading is the only effective mitigation.
How to confirm the fix worked
To validate the fix, check the installed version of the Multer package within your Node.js project. Run `npm list multer` or `yarn list --pattern multer` in the project's root directory and ensure the resolved version is 2.1.0 or higher. Additionally, review the `package-lock.json` or `yarn.lock` file to confirm that no sub-dependencies are pulling in a vulnerable version of Multer.
Typical attack path
- Attacker identifies a target web application built with Node.js that handles file uploads.
- Attacker probes the application to confirm it uses a vulnerable version of the Multer middleware.
- Attacker crafts a malformed multipart/form-data HTTP request designed to trigger the resource exhaustion flaw.
- Attacker sends the malicious request to an endpoint that uses Multer.
- The server's Node.js process consumes excessive resources, leading to a crash or unresponsiveness, causing a Denial of Service.
How to detect it
To detect potential exploitation attempts, monitor application logs for crashes or restarts of Node.js processes, particularly those associated with file upload endpoints. Correlate these events with spikes in server resource utilization (CPU, memory). Review web server access logs or application-level logs for HTTP POST requests to file upload endpoints that result in 4xx or 5xx error codes and appear to contain malformed multipart/form-data content, such as requests with unusual or missing boundaries or headers.
What your security team should do
- Identify all Node.js applications in your environment that use the Multer library for handling multipart/form-data, typically for file uploads.
- Prioritize patching for public-facing applications, as they are most exposed to this unauthenticated attack.
- Upgrade Multer to version 2.1.0 or later across all affected projects.
- Consider implementing rate-limiting or web application firewall (WAF) rules to block or throttle malformed multipart/form-data requests as a defense-in-depth measure, although this is not a substitute for patching.
The record
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | multer | 0 | 2.1.0 |
Related vulnerabilities
- GHSA-xf7r-hgr6-v32p Multer vulnerable to Denial of Service via incomplete cleanup Same vulnerability
- GHSA-72gw-mp4g-v24j Multer vulnerable to Denial of Service via deeply nested field names Also affects multer
- GHSA-3p4h-7m6x-2hcm Multer vulnerable to Denial of Service via incomplete cleanup of aborted uploads Also affects multer
- CVE-2026-5038 Impact: multer versions 2.0.0-alpha.1 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a… Also affects multer
- CVE-2026-5079 Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial… Also affects multer
- GHSA-5528-5vmv-3xc2 Multer Vulnerable to Denial of Service via Uncontrolled Recursion Also affects multer
- CVE-2026-3520 Multer is a node.js middleware for handling `multipart/form-data`. Also affects multer
- GHSA-v52c-386h-88mc Multer vulnerable to Denial of Service via resource exhaustion Also affects multer