CVE-2026-31908
Critical · 9.1CVSS
9.1
EPSS
0.6%
Published
Apr 14, 2026
CISA due date
—
The record
Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-54771 Langroid is a framework for building large-language-model-powered applications. CWE-75
- CVE-2026-29042 Nuclio is a "Serverless" framework for Real-Time Events and Data Processing. CWE-75
- CVE-2026-27120 Leafkit is a templating language with Swift-inspired syntax. CWE-75
- GHSA-4hfh-fch3-5q7p Leaf-kit html escaping does not work on characters that are part of extended grapheme… CWE-75
- CVE-2024-21503 Versions of the package black before 24.3.0 are vulnerable to Regular Expression Denial… CWE-75
- CVE-2024-0801 A denial of service vulnerability exists in Arcserve Unified Data Protection 9.2 and 8.1… CWE-75