Cloudanix VulnDB

CVE-2026-31841

Medium · 6.5

CVSS

6.5

EPSS

0.3%

Published

Mar 12, 2026

CISA due date

—

The record

Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

Affected packages

Ecosystem Package Introduced Fixed
npm hyperterse 2.0.0 2.2.0

Related vulnerabilities