Cloudanix VulnDB

CVE-2026-31840

Critical · 9.8

CVSS

9.8

EPSS

0.7%

Published

Mar 11, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.2 and 8.6.28, an attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. This vulnerability is fixed in 9.6.0-alpha.2 and 8.6.28.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.28
npm parse-server 9.0.0 9.6.0-alpha.2

Related vulnerabilities