CVE-2026-31818
Critical · 9.6CVSS
9.6
EPSS
0.4%
Published
Apr 3, 2026
CISA due date
—
The record
Budibase is an open-source low-code platform. Prior to version 3.33.4, a server-side request forgery (SSRF) vulnerability exists in Budibase's REST datasource connector. The platform's SSRF protection mechanism (IP blacklist) is rendered completely ineffective because the BLACKLIST_IPS environment variable is not set by default in any of the official deployment configurations. When this variable is empty, the blacklist function unconditionally returns false, allowing all requests through without restriction. This issue has been patched in version 3.33.4.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @budibase/backend-core | 0 | 3.33.4 |
Related vulnerabilities
- GHSA-7r9j-r86q-7g45 Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist Same vulnerability
- GHSA-wxq7-x3qp-vcr8 Budibase: Unanchored Regex in `matchers.ts` Allows CSRF Bypass via Query String Injection… Also affects @budibase/backend-core
- CVE-2026-48147 Budibase is an open-source low-code platform. Also affects @budibase/backend-core
- CVE-2026-46424 Budibase is an open-source low-code platform. Also affects @budibase/backend-core
- GHSA-6vp2-6r7m-2jvx Budibase: Missing Cache Invalidation on Public API Role Unassignment Allows Revoked Users… Also affects @budibase/backend-core
- CVE-2026-42239 Budibase is an open-source low-code platform. Also affects @budibase/backend-core
- CVE-2026-41428 Budibase is an open-source low-code platform. Also affects @budibase/backend-core
- GHSA-4f9j-vr4p-642r Budibase auth session cookies are set with httpOnly:false — any XSS can lead to full… Also affects @budibase/backend-core