Cloudanix VulnDB

CVE-2026-30962

Medium · 6.5

CVSS

6.5

EPSS

0.4%

Published

Mar 10, 2026

CISA due date

—

The record

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

Affected packages

Ecosystem Package Introduced Fixed
npm parse-server 0 8.6.19
npm parse-server 9.0.0 9.5.2-alpha.6

Related vulnerabilities