CVE-2026-28390
High · 7.5CVSS
7.5
EPSS
0.8%
Published
Apr 7, 2026
CISA due date
—
The record
Issue summary: During processing of a crafted CMS EnvelopedData message with KeyTransportRecipientInfo a NULL pointer dereference can happen. Impact summary: Applications that process attacker-controlled CMS data may crash before authentication or cryptographic operations occur resulting in Denial of Service. When a CMS EnvelopedData message that uses KeyTransportRecipientInfo with RSA-OAEP encryption is processed, the optional parameters field of RSA-OAEP SourceFunc algorithm identifier is examined without checking for its presence. This results in a NULL pointer dereference if the field is missing. Applications and services that call CMS_decrypt() on untrusted input (e.g., S/MIME processing or CMS-based protocols) are vulnerable. The FIPS modules in 3.6, 3.5, 3.4, 3.3 and 3.0 are not affected by this issue, as the affected code is outside the OpenSSL FIPS module boundary.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| openSUSE:Leap 16.0 | openssl-3 | 0 | 3.5.0-160000.7.1 |
| openSUSE:Tumbleweed | openssl-3 | 0 | 3.5.3-4.1 |
Related vulnerabilities
- CVE-2026-7383 Issue summary: A signed integer overflow when sizing the destination buffer for Unicode… Also affects openssl-3
- CVE-2026-9076 Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes… Also affects openssl-3
- CVE-2026-45446 Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452)… Also affects openssl-3
- CVE-2026-45447 Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a… Also affects openssl-3
- CVE-2026-45445 Issue summary: When an application drives an AES-OCB context through the public… Also affects openssl-3
- CVE-2026-42769 Issue Summary: An error in the callback used to verify the certificate provided in a Root… Also affects openssl-3
- CVE-2026-42768 Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to… Also affects openssl-3
- CVE-2026-42767 Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could… Also affects openssl-3