Cloudanix VulnDB

CVE-2026-27820

Critical · 9.8

CVSS

9.8

EPSS

0.8%

Published

Apr 16, 2026

CISA due date

—

The record

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities