CVE-2026-26269
Medium · 5.4CVSS
5.4
EPSS
0.6%
Published
Feb 13, 2026
CISA due date
—
The record
Vim is an open source, command line text editor. Prior to 9.1.2148, a stack buffer overflow vulnerability exists in Vim's NetBeans integration when processing the specialKeys command, affecting Vim builds that enable and use the NetBeans feature. The Stack buffer overflow exists in special_keys() (in src/netbeans.c). The while (*tok) loop writes two bytes per iteration into a 64-byte stack buffer (keybuf) with no bounds check. A malicious NetBeans server can overflow keybuf with a single specialKeys command. The issue has been fixed as of Vim patch v9.1.2148.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Mageia:9 | vim | 0 | 9.1.2148-1.mga9 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Micro 5.5 | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Server 15 SP5-LTSS | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Server 15 SP6-LTSS | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | vim | 0 | 9.2.0110-150500.20.43.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | vim | 0 | 9.2.0110-150500.20.43.1 |
| openSUSE:Leap 15.6 | vim | 0 | 9.2.0110-150500.20.43.1 |
| openSUSE:Leap 16.0 | vim | 0 | 9.2.0110-160000.1.1 |
Related vulnerabilities
- CVE-2026-28418 Vim is an open source, command line text editor. Also affects vim
- CVE-2026-28419 Vim is an open source, command line text editor. Also affects vim
- CVE-2026-28421 Vim is an open source, command line text editor. Also affects vim
- CVE-2026-28422 Vim is an open source, command line text editor. Also affects vim
- CVE-2026-28420 Vim is an open source, command line text editor. Also affects vim
- CVE-2026-28417 Vim is an open source, command line text editor. Also affects vim
- CVE-2025-29768 Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted… Also affects vim
- CVE-2025-27423 Vim is an open source, command line text editor. Also affects vim