CVE-2026-25514
High · 8.8CVSS
8.8
EPSS
0.6%
Published
Feb 4, 2026
CISA due date
—
The record
FacturaScripts is open-source enterprise resource planning and accounting software. Prior to version 2025.81, FacturaScripts contains a critical SQL injection vulnerability in the autocomplete functionality that allows authenticated attackers to extract sensitive data from the database including user credentials, configuration settings, and all stored business data. The vulnerability exists in the CodeModel::all() method where user-supplied parameters are directly concatenated into SQL queries without sanitization or parameterized binding. This issue has been patched in version 2025.81.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Packagist | facturascripts/facturascripts | 0 | 2025.81 |
Related vulnerabilities
- GHSA-pqqg-5f4f-8952 FacturaScripts has SQL Injection in Autocomplete Actions Same vulnerability
- CVE-2026-25513 FacturaScripts is open-source enterprise resource planning and accounting software. Also affects facturascripts/facturascripts
- GHSA-cjfx-qhwm-hf99 FacturaScripts has SQL Injection in API ORDER BY Clause Also affects facturascripts/facturascripts
- CVE-2026-23997 FacturaScripts is open-source enterprise resource planning and accounting software. Also affects facturascripts/facturascripts
- CVE-2026-23476 FacturaScripts is open-source enterprise resource planning and accounting software. Also affects facturascripts/facturascripts
- GHSA-4v7v-7v7r-3r5h FacturaScripts has Stored Cross-Site Scripting (XSS) in "Observations" field via History… Also affects facturascripts/facturascripts
- GHSA-g6w2-q45f-xrp4 FacturaScripts is Vulnerable to Reflected XSS Also affects facturascripts/facturascripts
- GHSA-2267-xqcf-gw2m FacturaScripts is Vulnerable to Stored Cross-Site Scripting (XSS) via XML File Upload Also affects facturascripts/facturascripts