CVE-2026-24778
High · 8.8CVSS
8.8
EPSS
0.3%
Published
Jan 27, 2026
CISA due date
—
The record
Ghost is an open source content management system. In Ghost versions 5.43.0 through 5.12.04 and 6.0.0 through 6.14.0, an attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. Ghost Portal versions 2.29.1 through 2.51.4 and 2.52.0 through 2.57.0 were vulnerable to this issue. Ghost automatically loads the latest patch of the members Portal component via CDN. For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability. v5.121.0 loads Portal v2.51.5, which contains the patch. For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability. v6.15.0 loads Portal v2.57.1, which contains the patch. For Ghost installations using a customized or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @tryghost/portal | 2.29.1 | 2.51.5 |
| npm | @tryghost/portal | 2.52.0 | 2.57.1 |
| npm | ghost | 5.43.0 | 5.121.0 |
| npm | ghost | 6.0.0 | 6.15.0 |
| Bitnami | ghost | 5.43.0 | 5.121.0 |
Related vulnerabilities
- GHSA-gv6q-2m97-882h Ghost vulnerable to XSS via malicious Portal preview links Same vulnerability
- CVE-2026-29784 Ghost is a Node.js content management system. Also affects ghost
- CVE-2026-29053 Ghost is a Node.js content management system. Also affects ghost
- GHSA-9m84-wc28-w895 Ghost has incomplete CSRF protections around OTC use Also affects ghost
- GHSA-cgc2-rcrh-qr5x Ghost Vulnerable to Remote Code Execution via Malicious Themes Also affects ghost
- CVE-2026-26980 Ghost is a Node.js content management system. Also affects ghost
- GHSA-w52v-v783-gw97 Ghost has a SQL injection in Content API Also affects ghost
- CVE-2026-22597 Ghost is a Node.js content management system. Also affects ghost