CVE-2026-2360
High · 8.0CVSS
8.0
EPSS
0.5%
Published
Feb 11, 2026
CISA due date
—
The record
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a custom operator in the public schema and place malicious code in that operator. This operator will later be executed with superuser privileges when the extension is created. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version. With PostgreSQL 15 and later, the creation permission on the public schema is revoked by default and this exploit can only be achieved if a superuser adds a new schema in her/his own search_path and grants the CREATE privilege on that schema to untrusted users, both actions being clearly discouraged by the PostgreSQL documentation. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-87530 Uncontrolled search path element in CredentialProvider in Google Chrome on on Windows… CWE-427
- CVE-2026-76199 Photoshop Desktop is affected by an Uncontrolled Search Path Element vulnerability that… CWE-427
- CVE-2026-45221 Konga before 2.1.0 contains a privilege escalation vulnerability that allows… CWE-427
- CVE-2026-19590 OpenAI Codex Desktop for Windows and macOS could execute attacker-controlled Git hooks… CWE-427
- CVE-2026-82649 SiYuan Windows installer before version 3.8.1 (affected versions >= 2.0.14) contains an… CWE-427
- CVE-2026-65093 NVIDIA OpenShell for Linux contains a vulnerability where an attacker could cause a… CWE-427
- CVE-2026-50773 An issue in CGM Germany - CompuGroup Medical CGM ISIS MED 2510.1.0.20 allows a remote… CWE-427
- CVE-2026-56090 Dell ObjectScale, versions prior to 4.3.0.1, contain(s) an Uncontrolled Search Path… CWE-427