Cloudanix VulnDB

CVE-2026-2052

High · 8.8

CVSS

8.8

EPSS

0.8%

Published

May 2, 2026

CISA due date

—

The record

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities