Cloudanix VulnDB

CVE-2026-1927

Medium · 5.4

CVSS

5.4

EPSS

0.2%

Published

Feb 5, 2026

CISA due date

—

The record

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the greenshift_app_pass_validation() function in all versions up to, and including, 12.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve global plugin settings including stored AI API keys and modify plugin settings, including the injection of arbitrary web scripts via the 'custom_css' value (stored XSS). NOTE: This vulnerability was partially patched in version 12.6.

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities