Cloudanix VulnDB

CVE-2026-18245

Critical · 9.0

CVSS

9.0

EPSS

1.0%

Published

Jul 30, 2026

CISA due date

—

The record

Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6

Affected packages

Ecosystem Package Introduced Fixed

Related vulnerabilities