CVE-2026-12957
High · 7.8CVSS
7.8
EPSS
0.2%
Published
Jun 23, 2026
CISA due date
—
The record
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-102282 adm-zip is a JavaScript library for creating and extracting ZIP archives in Node.js. CWE-732
- CVE-2026-92941 vm2 versions from 3.11.3 before 3.11.7 expose the host tls module to NodeVM sandbox code… CWE-732
- CVE-2026-87988 An arbitrary file access vulnerability in Mistral Vibe allows an attacker to bypass… CWE-732
- CVE-2026-19583 Velociraptor allows some sensitive artifacts to be gated by additional permissions. CWE-732
- CVE-2026-79617 Incorrect Permission Assignment for Critical Resource vulnerability in TÜBİTAK BİLGEM… CWE-732
- CVE-2026-82312 OpenVPN 2.0.0 through 2.6.22 and 2.7_alpha1 through 2.7.6 on Windows allows local… CWE-732
- CVE-2026-80112 PassMark PerformanceTest before 11.1 build 1012, BurnInTest before 11.1 build 1000, and… CWE-732
- CVE-2021-43613 An issue was discovered in SysPasswordDxe in Insyde InsydeH2O. CWE-732