CVE-2026-12249
Critical · 9.0CVSS
9.0
EPSS
0.1%
Published
Jun 22, 2026
CISA due date
—
The record
An issue was discovered in Canonical ADSys upstream versions through v0.16.2. During Active Directory Certificate Services (AD CS) certificate auto-enrollment via the vendored Samba client script (internal/policies/certificate/python/vendor_samba/gp/gp_cert_auto_enroll_ext.py), ADSys utilizes a plaintext HTTP connection (http://) instead of a secure HTTPS connection (https://) to request the CA certificate from the Active Directory Certificate Services server (GetCACert). An unauthenticated network attacker positioned between the managed Ubuntu host and the configured AD CS CA hostname can conduct a Man-in-the-Middle (MITM) attack. By intercepting the plaintext HTTP request, the attacker can supply an arbitrary, attacker-controlled Root CA certificate. Because the system automatically accepts this certificate and registers it into the local system trust store via update-ca-certificates, this results in system-wide trust store poisoning. Consequently, TLS clients utilizing the operating system trust store on the affected machine will accept rogue certificates for arbitrary domains, enabling persistent decryption and interception of subsequent TLS connections. This issue is resolved in version v0.16.3.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-112378 GitLab has remediated an issue in GitLab EE affecting all versions from 17.8 before… CWE-348
- CVE-2026-102275 PyJWT is a Python implementation of JSON Web Token standards. CWE-348
- CVE-2026-90711 proxy-addr is a Node.js module that determines a request's client address behind trusted… CWE-348
- CVE-2026-16732 fastify is a fast and low overhead web framework for Node.js. CWE-348
- CVE-2026-25552 Ghost CLI before 1.30.1 contains an IP spoofing vulnerability that allows unauthenticated… CWE-348
- CVE-2026-63220 CodeIgniter is a PHP full-stack web framework. CWE-348
- CVE-2026-50243 In NLnet Labs Unbound 1.6.2 up to and including 1.25.1, when Unbound is configured with… CWE-348
- CVE-2026-63770 Glance through 0.8.5 contains an IP address spoofing vulnerability in the authentication… CWE-348