CVE-2026-120597
Medium · 4.3CVSS
4.3
EPSS
0.3%
Published
Nov 2, 2026
CISA due date
—
The record
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-115541 HumHub Community Edition 1.19.0 contains a stored cross-site scripting vulnerability in… CWE-79
- CVE-2026-82160 Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper… CWE-79
- CVE-2026-82161 Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper… CWE-79
- CVE-2026-82158 Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper… CWE-79
- CVE-2026-82159 Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper… CWE-79
- CVE-2025-71451 Vembu BDRSuite before 7.6.0 contains an unauthenticated cross-site scripting… CWE-79
- CVE-2025-71452 Vembu BDRSuite before 7.6.0 contains an unauthenticated cross-site scripting… CWE-79
- CVE-2026-63197 traQ is a messenger application built for Digital Creators Club traP. CWE-79