CVE-2026-117531
Medium · 5.9CVSS
5.9
EPSS
0.3%
Published
Nov 2, 2026
CISA due date
—
The record
@fastify/multipart is the multipart form-data and file upload plugin for the Fastify web framework. In versions 5.3.0 through 10.1.6, the plugin does not propagate a parser error to the file stream when a request body ends inside a file part with no closing boundary, even though the Content-Length is complete, the client does not abort, and no file size limit is exceeded. The plugin destroys the in-progress file stream without an error, so a handler that iterates the request parts and performs asynchronous work before consuming the file attaches to a stream that never emits an error or end event, and the request never responds while the connection stays open. An unauthenticated remote client can repeat these malformed uploads against such a route to accumulate pending connections and exhaust server resources, so the impact is availability only and exploitation depends on the application using a delayed file consumer. The issue is fixed in @fastify/multipart 10.1.7, where the parser error is propagated to the file stream so a delayed consumer settles with an error instead of hanging, and users should upgrade to 10.1.7 or later. There is no workaround other than upgrading.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-116668 Tanium addressed an uncontrolled resource consumption vulnerability in Discover. CWE-400
- CVE-2026-111751 Angular is a development platform for building mobile and desktop web applications using… CWE-400
- CVE-2026-111752 Angular is a development platform for building mobile and desktop web applications using… CWE-400
- CVE-2026-63476 isomorphic-git is a pure JavaScript implementation of Git for Node.js and browsers. CWE-400
- CVE-2026-121444 svg-sanitizer from 0.11.0 before 1.1.0 contains an algorithmic complexity denial of… CWE-400
- CVE-2026-121438 Mistune before 3.3.3 contains a denial of service vulnerability in… CWE-400
- CVE-2026-121404 FreeRDP before 3.32.2 contains a denial of service vulnerability in the shadow server… CWE-400
- CVE-2026-49924 In ShortcutInfo of ShortcutInfo.java, there is a possible way to crash the launcher via… CWE-400