CVE-2026-114612
Critical · 9.9CVSS
9.9
EPSS
0.3%
Published
Oct 22, 2026
CISA due date
—
The record
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|
Related vulnerabilities
- CVE-2026-63339 IXP Manager is a full-stack web application for managing Internet Exchange Points. CWE-269
- CVE-2026-62990 Shopper is a Headless e-commerce Admin Panel. CWE-269
- CVE-2026-61850 Kargo manages and automates the promotion of software artifacts. CWE-269
- CVE-2026-118205 The Essential Addons for Elementor – Popular Elementor Templates & Widgets plugin for… CWE-269
- CVE-2026-105894 The Ak Framework plugin for WordPress, included in the Newsy - Viral News & Magazine… CWE-269
- CVE-2026-101213 Dell OpenManage Enterprise, versions prior to 4.8.0, contains an Improper Privilege… CWE-269
- CVE-2026-59386 A SpaceSupporter could improperly modify an application's start command and… CWE-269
- CVE-2026-113616 The LogixFast Auth WordPress plugin before 1.0.4 does not deliver its password-reset… CWE-269