CVE-2025-68615
Critical · 9.8CVSS
9.8
EPSS
42.4%
Published
Dec 23, 2025
CISA due date
—
The record
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| AlmaLinux:10 | net-snmp | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | net-snmp-agent-libs | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | net-snmp-devel | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | net-snmp-libs | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | net-snmp-perl | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | net-snmp-perl-module | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | net-snmp-utils | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:10 | python3-net-snmp | 0 | 1:5.9.4-15.el10_1.2 |
| AlmaLinux:8 | net-snmp | 0 | 1:5.8-33.el8_10 |
| AlmaLinux:8 | net-snmp-agent-libs | 0 | 1:5.8-33.el8_10 |
| AlmaLinux:8 | net-snmp-devel | 0 | 1:5.8-33.el8_10 |
| AlmaLinux:8 | net-snmp-libs | 0 | 1:5.8-33.el8_10 |
| AlmaLinux:8 | net-snmp-perl | 0 | 1:5.8-33.el8_10 |
| AlmaLinux:8 | net-snmp-utils | 0 | 1:5.8-33.el8_10 |
| AlmaLinux:9 | net-snmp | 0 | 1:5.9.1-17.el9_7.1 |
| AlmaLinux:9 | net-snmp-agent-libs | 0 | 1:5.9.1-17.el9_7.1 |
| AlmaLinux:9 | net-snmp-devel | 0 | 1:5.9.1-17.el9_7.1 |
| AlmaLinux:9 | net-snmp-libs | 0 | 1:5.9.1-17.el9_7.1 |
| AlmaLinux:9 | net-snmp-perl | 0 | 1:5.9.1-17.el9_7.1 |
| AlmaLinux:9 | net-snmp-utils | 0 | 1:5.9.1-17.el9_7.1 |
| AlmaLinux:9 | python3-net-snmp | 0 | 1:5.9.1-17.el9_7.1 |
| Mageia:9 | net-snmp | 0 | 5.9.3-2.2.mga9 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | net-snmp | 0 | 5.9.4-150600.24.10.1 |
| SUSE:Linux Enterprise Module for Package Hub 15 SP7 | net-snmp | 0 | 5.9.4-150600.24.10.1 |
| SUSE:Linux Enterprise Server 15 SP6-LTSS | net-snmp | 0 | 5.9.4-150600.24.10.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | net-snmp | 0 | 5.9.4-150600.24.10.1 |
| openSUSE:Leap 15.6 | net-snmp | 0 | 5.9.4-150600.24.10.1 |
| openSUSE:Leap 16.0 | net-snmp | 0 | 5.9.4-160000.3.1 |
| openSUSE:Tumbleweed | net-snmp | 0 | 5.9.5.2-1.1 |
Related vulnerabilities
- CVE-2015-5621 The snmp_pdu_parse function in snmp_api.c in net-snmp 5.7.2 and earlier does not remove… Also affects net-snmp
- CVE-2014-3565 snmplib/mib.c in net-snmp 5.7.0 and earlier, when the -OQ option is used, allows remote… Also affects net-snmp
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-119
- CVE-2026-112073 A vulnerability was identified in Tencent ncnn up to 44b02dabdcf97499281a4692ebd65bad73dc… CWE-119
- CVE-2026-90831 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90804 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90803 A security vulnerability has been detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90801 A security flaw has been discovered in GNU Binutils 2.47. CWE-119