Cloudanix VulnDB

CVE-2025-68476

None

CVSS

—

EPSS

0.6%

Published

Dec 22, 2025

CISA due date

—

The record

KEDA is a Kubernetes-based Event Driven Autoscaling component. Prior to versions 2.17.3 and 2.18.3, an Arbitrary File Read vulnerability has been identified in KEDA, potentially affecting any KEDA resource that uses TriggerAuthentication to configure HashiCorp Vault authentication. The vulnerability stems from an incorrect or insufficient path validation when loading the Service Account Token specified in spec.hashiCorpVault.credential.serviceAccount. An attacker with permissions to create or modify a TriggerAuthentication resource can exfiltrate the content of any file from the node's filesystem (where the KEDA pod resides) by directing the file's content to a server under their control, as part of the Vault authentication request. The potential impact includes the exfiltration of sensitive system information, such as secrets, keys, or the content of files like /etc/passwd. This issue has been patched in versions 2.17.3 and 2.18.3.

Affected packages

Ecosystem Package Introduced Fixed
Go github.com/kedacore/keda 0 No fix
Go github.com/kedacore/keda/v2 0 2.17.3
Go github.com/kedacore/keda/v2 2.18.0 2.18.3
Chainguard k8sgpt 0 0.4.27-r1
Chainguard keda-2.16-compat 0 2.16.1-r21
Chainguard keda-fips-2.16-compat 0 2.16.1-r14
Chainguard kserve 0 0.16.0-r7
Chainguard kserve-agent 0 0.16.0-r7
Chainguard kserve-agent-compat 0 0.16.0-r7
Chainguard kserve-manager 0 0.16.0-r7
Chainguard kserve-manager-compat 0 0.16.0-r7
Chainguard kserve-qpext 0 0.16.0-r7
Chainguard kserve-qpext-compat 0 0.16.0-r7
Chainguard kserve-router 0 0.16.0-r7
Chainguard kserve-router-compat 0 0.16.0-r7
Chainguard kserve-storage-controller 0 0.16.0-r7
Chainguard verticadb-operator-compat 0 25.4.0.0-r2
Chainguard verticadb-operator-fips-compat 0 25.4.0.0-r3
Wolfi k8sgpt 0 0.4.27-r1
Wolfi keda-2.16-compat 0 2.16.1-r21
Wolfi kserve 0 0.16.0-r7
Wolfi kserve-agent 0 0.16.0-r7
Wolfi kserve-agent-compat 0 0.16.0-r7
Wolfi kserve-manager 0 0.16.0-r7
Wolfi kserve-manager-compat 0 0.16.0-r7
Wolfi kserve-qpext 0 0.16.0-r7
Wolfi kserve-qpext-compat 0 0.16.0-r7
Wolfi kserve-router 0 0.16.0-r7
Wolfi kserve-router-compat 0 0.16.0-r7
Wolfi kserve-storage-controller 0 0.16.0-r7
Wolfi verticadb-operator-compat 0 25.4.0.0-r2
go github.com/kedacore/keda/v2 2.18.0 2.18.3
openSUSE:Leap 15.6 govulncheck-vulndb 0 0.0.20251230T014957-150000.1.134.1

Related vulnerabilities