Cloudanix VulnDB

CVE-2025-68145

Critical · 9.1

CVSS

9.1

EPSS

7.0%

Published

Dec 17, 2025

CISA due date

—

The record

In mcp-server-git versions prior to 2025.12.17, when the server is started with the --repository flag to restrict operations to a specific repository path, it did not validate that repo_path arguments in subsequent tool calls were actually within that configured path. This could allow tool calls to operate on other repositories accessible to the server process. The fix adds path validation that resolves both the configured repository and the requested path (following symlinks) and verifies the requested path is within the allowed repository before executing any git operations. Users are advised to upgrade to 2025.12.17 upon release to remediate this issue.

Affected packages

Ecosystem Package Introduced Fixed
PyPI mcp-server-git 0 2025.12.18

Related vulnerabilities