CVE-2025-67746
Medium · 4.3CVSS
4.3
EPSS
0.5%
Published
Dec 30, 2025
CISA due date
—
The record
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Packagist | composer/composer | 2.0.0 | 2.2.26 |
| Packagist | composer/composer | 2.3.0 | 2.9.3 |
| Bitnami | composer | 2.0.0 | 2.2.26 |
| SUSE:Linux Enterprise Module for Web and Scripting 15 SP7 | php-composer2 | 0 | 2.6.4-150600.3.6.1 |
| openSUSE:Leap 15.6 | php-composer2 | 0 | 2.6.4-150600.3.6.1 |
| openSUSE:Tumbleweed | php-composer2 | 0 | 2.9.3-1.1 |
| packagist | composer/composer | 2.0.0 | 2.2.26 |
| packagist | composer/composer | 2.3.0 | 2.9.3 |
Related vulnerabilities
- GHSA-59pp-r3rg-353g Composer is vulnerable to ANSI sequence injection Same vulnerability
- CVE-2024-35242 Composer is a dependency manager for PHP. Also affects composer/composer
- CVE-2024-35241 Composer is a dependency manager for PHP. Also affects composer/composer
- CVE-2026-40176 Composer is a dependency manager for PHP. Also affects php-composer2
- CVE-2026-40261 Composer is a dependency manager for PHP. Also affects php-composer2
- CVE-2026-114577 A vulnerability was found in oretnom23 php-travel-agency-system. CWE-74
- CVE-2026-114575 A flaw has been found in TOTOLINK A950RG 4.1.2cu.5268_B20221104. CWE-74
- CVE-2026-112150 A security flaw has been discovered in vraj404 Criminal-Management-System up to… CWE-74