CVE-2025-67489
Critical · 9.8CVSS
9.8
EPSS
0.8%
Published
Dec 9, 2025
CISA due date
—
The record
@vitejs/plugin-rs provides React Server Components (RSC) support for Vite. Versions 0.5.5 and below are vulnerable to arbitrary remote code execution on the development server through unsafe dynamic imports in server function APIs (loadServerAction, decodeReply, decodeAction) when integrated into RSC applications that expose server function endpoints. Attackers with network access to the development server can read/modify files, exfiltrate sensitive data (source code, environment variables, credentials), or pivot to other internal services. While this affects development servers only, the risk increases when using vite --host to expose the server on all network interfaces. This issue is fixed in version 0.5.6.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @vitejs/plugin-rsc | 0 | 0.5.6 |
Related vulnerabilities
- GHSA-j76j-5p5g-9wfr @vitejs/plugin-rsc Remote Code Execution through unsafe dynamic imports in RSC server… Same vulnerability
- GHSA-w94c-4vhp-22gx @vitejs/plugin-rsc has a Denial of Service Vulnerability in React Server Components Also affects @vitejs/plugin-rsc
- GHSA-v457-wxvj-p9w9 @vitejs/plugin-rsc has a Denial of Service with React Server Components Also affects @vitejs/plugin-rsc
- GHSA-g239-q96q-x4qm @vitejs/plugin-rsc has an Arbitrary File Read via `/__vite_rsc_findSourceMapURL` Endpoint Also affects @vitejs/plugin-rsc
- CVE-2025-68155 @vitejs/plugin-rs provides React Server Components (RSC) support for Vite. Also affects @vitejs/plugin-rsc
- GHSA-c6m7-q6pr-c64r Vite Plugin React has a Source Code Exposure Vulnerability in React Server Components Also affects @vitejs/plugin-rsc
- GHSA-cpqf-f22c-r95x Vite Plugin React has a Denial of Service Vulnerability in React Server Components Also affects @vitejs/plugin-rsc
- GHSA-fmh4-wr37-44fp React Server Components are Vulnerable to RCE Also affects @vitejs/plugin-rsc