Cloudanix VulnDB

CVE-2025-66648

High · 7.2

CVSS

7.2

EPSS

0.2%

Published

Jan 5, 2026

CISA due date

—

The record

vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.

Affected packages

Ecosystem Package Introduced Fixed
npm vega-functions 0 6.1.1

Related vulnerabilities