Cloudanix VulnDB

CVE-2025-66169

Medium · 5.3

Apache Camel camel-neo4j component is vulnerable to cypher injection

CVSS

5.3

EPSS

0.6%

Published

Jan 14, 2026

CISA due date

—

The record

Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

Affected packages

Ecosystem Package Introduced Fixed
Maven org.apache.camel:camel-neo4j 4.10.0 4.10.8
Maven org.apache.camel:camel-neo4j 4.14.0 4.14.3
Maven org.apache.camel:camel-neo4j 4.15.0 4.17.0
maven org.apache.camel/camel-neo4j 4.10.0 4.10.8
maven org.apache.camel/camel-neo4j 4.14.0 4.14.3
maven org.apache.camel/camel-neo4j 4.15.0 4.17.0

Related vulnerabilities