Cloudanix VulnDB

CVE-2025-65965

None

CVSS

—

EPSS

0.1%

Published

Nov 25, 2025

CISA due date

—

The record

Grype is a vulnerability scanner for container images and filesystems. A credential disclosure vulnerability was found in Grype, affecting versions 0.68.0 through 0.104.0. If registry credentials are defined and the output of grype is written using the --file or --output json=<file> option, the registry credentials will be included unsanitized in the output file. This issue has been patched in version 0.104.1. Users running affected versions of grype can work around this vulnerability by redirecting stdout to a file instead of using the --file or --output options.

Affected packages

Ecosystem Package Introduced Fixed
Go github.com/anchore/grype 0.68.0 0.104.1
Chainguard cg 0 0.2.180-r0
Chainguard chainctl 0 0.2.180-r0
Chainguard docker-credential-cgr 0 0.2.180-r0
Chainguard k9s 0 0.50.16-r4
Chainguard zarf 0 0.67.0-r0
SUSE:Linux Enterprise Module for Package Hub 15 SP6 govulncheck-vulndb 0 0.0.20251209T172047-150000.1.127.1
Wolfi k9s 0 0.50.16-r4
Wolfi zarf 0 0.67.0-r0
go github.com/anchore/grype 0.68.0 0.104.1
openSUSE:Leap 15.6 govulncheck-vulndb 0 0.0.20251209T172047-150000.1.127.1

Related vulnerabilities