CVE-2025-65942
Low · 2.7CVSS
2.7
EPSS
0.3%
Published
Nov 25, 2025
CISA due date
—
The record
VictoriaMetrics is a scalable solution for monitoring and managing time series data. In versions from 1.0.0 to before 1.110.23, from 1.111.0 to before 1.122.8, and from 1.123.0 to before 1.129.1, affected versions are vulnerable to DoS attacks because the snappy decoder ignored VictoriaMetrics request size limits allowing malformed blocks to trigger excessive memory use. This could lead to OOM errors and service instability. The fix enforces block-size checks based on MaxRequest limits. This issue has been patched in versions 1.110.23, 1.122.8, and 1.129.1.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Go | github.com/VictoriaMetrics/VictoriaMetrics | 0 | 1.110.23 |
| Go | github.com/VictoriaMetrics/VictoriaMetrics | 1.0.0 | 1.110.23 |
| Go | github.com/VictoriaMetrics/VictoriaMetrics | 1.111.0 | 1.122.8 |
| Go | github.com/VictoriaMetrics/VictoriaMetrics | 1.123.0 | 1.129.1 |
| Chainguard | victoriametrics-operator-fips | 0 | 0.65.0-r2 |
| go | github.com/VictoriaMetrics/VictoriaMetrics | 1.0.0 | 1.110.23 |
| go | github.com/VictoriaMetrics/VictoriaMetrics | 1.111.0 | 1.122.8 |
| go | github.com/VictoriaMetrics/VictoriaMetrics | 1.123.0 | 1.129.1 |
| openSUSE:Leap 15.6 | govulncheck-vulndb | 0 | 0.0.20251230T014957-150000.1.134.1 |
Related vulnerabilities
- GO-2025-4161 VictoriaMetrics' Snappy Decoder DoS Vulnerability is Causing OOM in… Same vulnerability
- CVE-2026-33990 Docker Model Runner (DMR) is software used to manage, run, and deploy AI models using… Also affects govulncheck-vulndb
- CVE-2026-34204 MinIO is a high-performance object storage system. Also affects govulncheck-vulndb
- CVE-2026-34041 act is a project which allows for local running of github actions. Also affects govulncheck-vulndb
- CVE-2026-34042 act is a project which allows for local running of github actions. Also affects govulncheck-vulndb
- CVE-2026-34040 Moby is an open source container framework. Also affects govulncheck-vulndb
- CVE-2026-33997 Moby is an open source container framework. Also affects govulncheck-vulndb
- CVE-2026-27018 Gotenberg is an API for converting document formats. Also affects govulncheck-vulndb