CVE-2025-6170
Low · 2.5CVSS
2.5
EPSS
0.3%
Published
Jun 16, 2025
CISA due date
—
Cloudanix analysis
A command-line tool that reads XML files can crash if someone types an extremely long command into it while using the same computer, though doing so is difficult and unlikely to cause serious problems.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- High
- Impact
- Denial Of Service
- Component
- Application
- Class
- Buffer Overflow
- Remediation
- No Fix Yet
- Effort
- Other
- Patch risk
- Other
What it actually does
Buffer overflow in xmllint interactive shell from missing bounds check on long user commands, resulting in crash or potential arbitrary code execution in configurations lacking ASLR/DEP.
Why it matters to the business
Limited local denial-of-service risk on affected systems with low likelihood of exploitation due to high attack complexity and requirement for local interactive access; minimal operational disruption expected given low EPSS and absence from known exploited lists.
How an attack unfolds
An attacker with local access and user interaction launches the xmllint shell and supplies an excessively long command string to overflow the buffer, potentially hijacking control flow in unprotected environments.
How to fix it
Upgrade vlc on Mageia 5 to version 2.2.2-1.mga5.tainted; avoid interactive xmllint usage and ensure memory protections are enabled on legacy systems.
How to confirm the fix worked
Verify installed vlc version matches or exceeds the fixed release; attempt reproduction with long inputs to confirm absence of crash.
Typical attack path
- Obtain local system access
- Invoke xmllint in interactive mode
- Supply command exceeding input buffer limits
- Trigger overflow to cause crash or code execution
How to detect it
Review system and application logs for xmllint or vlc crashes; inspect shell histories for unusually long command strings targeting the interactive prompt.
What your security team should do
- Apply the specified vlc package update immediately
- Disable interactive shell access where feasible
- Monitor for local process crashes involving xmllint
The record
A flaw was found in the interactive shell of the xmllint command-line tool, used for parsing XML files. When a user inputs an overly long command, the program does not check the input size properly, which can cause it to crash. This issue might allow attackers to run harmful code in rare configurations without modern protections.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | libxml2 | 0 | No fix |
| Debian:12 | libxml2 | 0 | No fix |
| Debian:13 | libxml2 | 0 | No fix |
| Debian:14 | libxml2 | 0 | 2.12.7+dfsg+really2.9.14-2.1 |
| Mageia:9 | libxml2 | 0 | 2.10.4-1.8.mga9 |
| Mageia:9 | libxslt | 0 | 1.1.38-1.2.mga9 |
| SUSE:Enterprise Storage 7.1 | libxml2 | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Enterprise Storage 7.1 | python-libxml2-python | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | libxml2 | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | python-libxml2-python | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Micro 5.1 | libxml2 | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Micro 5.2 | libxml2 | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Micro 5.2 | python-libxml2-python | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Micro 5.5 | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Micro 5.5 | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | libxml2 | 0 | 2.12.10-150700.4.3.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | libxml2-python | 0 | 2.12.10-150700.4.3.1 |
| SUSE:Linux Enterprise Module for Python 3 15 SP6 | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Module for Python 3 15 SP7 | libxml2-python | 0 | 2.12.10-150700.4.3.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | libxml2 | 0 | 2.9.4-46.87.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | python-libxml2 | 0 | 2.9.4-46.87.1 |
| SUSE:Linux Enterprise Server 15 SP3-LTSS | libxml2 | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Server 15 SP3-LTSS | python-libxml2-python | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Server 15 SP5-LTSS | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Server 15 SP5-LTSS | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | libxml2 | 0 | 2.9.4-46.87.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | python-libxml2 | 0 | 2.9.4-46.87.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | libxml2 | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | python-libxml2-python | 0 | 2.9.7-150000.3.82.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| openSUSE:Leap 15.6 | libxml2 | 0 | 2.10.3-150500.5.29.1 |
| openSUSE:Leap 15.6 | libxml2-python | 0 | 2.10.3-150500.5.29.1 |
| openSUSE:Leap 15.6 | python-libxml2-python | 0 | 2.9.7-150000.3.82.1 |
| openSUSE:Tumbleweed | libxml2 | 0 | 2.13.8-2.1 |
Related vulnerabilities
- CVE-2025-9714 Uncontrolled recursion in XPath evaluation in libxml2 up to and including version 2.9.14… Also affects libxml2
- CVE-2025-8732 A vulnerability was found in libxml2 up to 2.14.5. Also affects libxml2
- CVE-2025-49796 A vulnerability was found in libxml2. Also affects libxml2
- CVE-2025-49795 A NULL pointer dereference vulnerability was found in libxml2 when processing XPath XML… Also affects libxml2
- CVE-2025-49794 A use-after-free vulnerability was found in libxml2. Also affects libxml2
- CVE-2025-6021 A flaw was found in libxml2's xmlBuildQName function, where integer overflows in buffer… Also affects libxml2
- CVE-2025-32415 In libxml2 before 2.13.8 and 2.14.x before 2.14.2, xmlSchemaIDCFillNodeTables in… Also affects libxml2
- CVE-2025-32414 In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur… Also affects libxml2