Cloudanix VulnDB

CVE-2025-61622

Critical · 9.8

Apache Pyfory python is vulnerable to deserialization of untrusted data

CVSS

9.8

EPSS

45.1%

Published

Oct 1, 2025

CISA due date

—

The record

Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.

Affected packages

Ecosystem Package Introduced Fixed
PyPI pyfory 0.12.0 0.12.3
PyPI pyfury 0.1.0 No fix
pypi pyfory 0.12.0 No fix
pypi pyfury 0.1.0 No fix

Related vulnerabilities