CVE-2025-6052
Low · 3.7CVSS
3.7
EPSS
0.5%
Published
Jun 13, 2025
CISA due date
—
Cloudanix analysis
A programming error in a common system library can let specially crafted data cause programs to crash or write to the wrong memory, which may interrupt normal operation until the software is updated.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- High
- Impact
- Denial Of Service
- Component
- Library
- Class
- Buffer Overflow
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Integer overflow in GString size calculation when appending data to an already-large string allows out-of-bounds memory write, resulting in crashes or memory corruption.
Why it matters to the business
Applications processing untrusted string input may crash or behave unpredictably, causing service disruption; the issue affects widely used GNOME libraries so many desktop and server programs are exposed until patched.
How an attack unfolds
An attacker supplies crafted input that forces a GString to exceed the size where its internal length calculation silently overflows, causing subsequent writes to occur beyond the allocated buffer and potentially corrupt adjacent memory.
How to fix it
Upgrade GLib and all dependent packages to versions containing the corrected GString logic; for the affected Mageia package, update gnome-photos to 3.14.2-1.1.mga5 or later.
How to confirm the fix worked
Confirm the installed GLib and gnome-photos package versions match or exceed the fixed releases; recompile or retest applications that exercise large-string append paths to verify absence of the overflow condition.
Typical attack path
- Identify an application that uses GLib GString to handle attacker-controlled strings
- Send a specially sized input that triggers the length-calculation overflow
- Trigger the append operation that performs the out-of-bounds write
- Observe crash or attempt to leverage resulting memory corruption for further impact
How to detect it
Review application and system logs for unexpected crashes or segmentation faults in processes linked against GLib when processing large strings; correlate with any recent changes in string-handling code paths.
What your security team should do
- Apply the listed package updates immediately on all affected systems
- Prioritize patching in environments that accept untrusted input into GLib-based string handling
- Monitor vendor advisories for additional GLib-dependent packages that may require the same fix
The record
A flaw was found in how GLib’s GString manages memory when adding data to strings. If a string is already very large, combining it with more input can cause a hidden overflow in the size calculation. This makes the system think it has enough memory when it doesn’t. As a result, data may be written past the end of the allocated memory, leading to crashes or memory corruption.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:13 | glib2.0 | 0 | No fix |
| Debian:14 | glib2.0 | 0 | 2.84.3-1 |
| Mageia:9 | glib2.0 | 0 | 2.76.3-1.5.mga9 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | glib2 | 0 | 2.78.6-150600.4.16.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | glib2 | 0 | 2.78.6-150600.4.16.1 |
| openSUSE:Leap 15.6 | glib2 | 0 | 2.78.6-150600.4.16.1 |
| openSUSE:Leap 15.6 | glib2-doc | 0 | 2.78.6-150600.4.16.1 |
| openSUSE:Tumbleweed | glib2 | 0 | 2.84.3-1.1 |
Related vulnerabilities
- CVE-2025-7039 A flaw was found in glib. Also affects glib2.0
- CVE-2025-4373 A flaw was found in GLib, which is vulnerable to an integer overflow in the… Also affects glib2.0
- CVE-2025-3360 A flaw was found in GLib. Also affects glib2.0
- CVE-2024-52533 gio/gsocks4aproxy.c in GNOME GLib before 2.82.1 has an off-by-one error and resultant… Also affects glib2.0
- CVE-2024-34397 An issue was discovered in GNOME GLib before 2.78.5, and 2.79.x and 2.80.x before 2.80.1. Also affects glib2.0
- CVE-2023-32611 A flaw was found in GLib. Also affects glib2.0
- CVE-2026-0988 A flaw was found in glib. Also affects glib2.0
- CVE-2025-14512 A flaw was found in glib. Also affects glib2.0